Jump to content
psybient.org community members forum - share good vibes and enjoy
=ҒLΦɎD=

Xone K2 issues (mapping midi)

Recommended Posts

Right, the old ones are better!

 

So yeah, I got me a new one (with yosemite) and i have problems :)

Traktor runs OK, but the problem are the controllers...

Normally I use an Xone K2 and a mapping.

At first it all works, but then, after a few hours, problems are starting...

Faders dissapear, decks stop working etc.

So after a while, you don't have any control anymore, it all fails one after another.

The only controller that works is my old NI Z1...

 

I read that all problems start because of some drivers in the Yosemite-version: 

https://www.native-instruments.com/en/support/knowledge-base/show/3078/my-ni-application-does-not-launch-under-mac-os-10.10-yosemite/

Anyone has done that (i guess not because all of you smart asses have an old MBP :))

Share this post


Link to post
Share on other sites

i'm not sure if your problem is model sepcific or just an OS problem.

 

I did read somewhere though that the new Macbooks are doing very well in terms of build reliability though.  I guess this is because they are welding the components in now.

 

So maybe you did do the right thing..

 

I also went for the old one beacuse it has firewire and I have a firewire hard drive and audio interface already.  USB3 is probably the most useful connection now.

Share this post


Link to post
Share on other sites

A&H says i don't need drivers, but i updated the firmware, thx for that tip spatialize!

when i was intalling the firmware i had numerous errors, so i had to rescan my audio midi setup (so yes, did that G)

so that is also OK now! :)

but still... no mapping works 100%...

i used a mapping i'm used to play with (http://www.traktorbible.com/freaks/mappingview.aspx?id=775)

now, i have sound but no control.. no faders or knobs are working..

*sigh*

Share this post


Link to post
Share on other sites

I think it's OS related.

I mean, de mappings of my Xone worked perfect on windows

and now they don't on OS...

 

I'd like to know what controllers do work on Yosemite, didn't found that info yet.

Anybody any idea?

 

I would recommend an upgrade to "el capitan".
There is technically no reason speaks against the upgrade ... frist release was 10.11. ( September 30, 2015 ) ... Current release is 10.11.3  ( January 19, 2016 )

Share this post


Link to post
Share on other sites

are you running the latest version of traktor?

 

maybe check the specs of your version of traktor against the OS you have?

 

do you have any other software you can check controller assignements?

 

if it works ok in other software then it may be traktor that is the problem?

 

weird that it loses its assignments after a while though,,, mmmmmm

Share this post


Link to post
Share on other sites

 

I would recommend an upgrade to "el capitan".
There is technically no reason speaks against the upgrade ... frist release was 10.11. ( September 30, 2015 ) ... Current release is 10.11.3  ( January 19, 2016 )

 

yes, that is an option, but i have no idea in how it will change things.

 

 

are you running the latest version of traktor?

 

maybe check the specs of your version of traktor against the OS you have?

 

do you have any other software you can check controller assignements?

 

if it works ok in other software then it may be traktor that is the problem?

 

weird that it loses its assignments after a while though,,, mmmmmm

 

it is the most recent version of trakor ( i downloaded it 14 days ago just after i got my MBP).

so both are recent.

 

other software, you mean stuff like VirtualDj? yes i have that, so i could try that out.

i know the xone (with mapping) worked perfect with a window based version of traktor.

 

yeah it's very wierd :)

my old NI Z1 works without a glitch and i'm getting and X1 mk2 tomorrow, it lookz like NI harware and software are still working togheter...(i'm not talking about S5 en S8 here :))

Share this post


Link to post
Share on other sites

Any other software where you can check the controllers. Ableton had very good controller implementation imo.

 

Make sure that the latest version of traktor does not require el capitan ( I'd be shocked if it did but it's worth a check).

 

Wonder if it's anything to do with the usb ports or even a cable. Try a different cable and different port perhaps?

 

Process of elimination leads to illumination :-)

Share this post


Link to post
Share on other sites

i noticiced that sometimes midi signals are send on different channels then then one defined in mapping.
as i remember i was not able to use the existing k2 mapping from internet and i had to make my own.
you can try it. just to see if it works. =>  https://www.sendspace.com/file/kkukiy

 

when i were trying update of firmware i also had milions of problems, but it works fine. just need to rescan midi once in a while. but works very stable for me.

Share this post


Link to post
Share on other sites

and te soap continuous...

 

new i have a mapping that works (thank you Iurri!)

but now, everytime i fire up my MBP the controller doens't give a bleep!

 

i have to check my audio midi setup, rescan MIDI and test setup...and than it works again...

 

this is getting so hilarious i can cry! :)

Share this post


Link to post
Share on other sites

yup did all of that my friend :)

 

after all the hassle with the Xone, i got me and X1 midi controller, that one fits right next to the Z1.

so now i have all the control i want and it's plug & play :)

no more problems with these 2, and i'm happy about that :)

 

I use the same set. It really doesn't get simpler.

Share this post


Link to post
Share on other sites

Mønsterhed,

 

i believe that is related to midi protocol and it takes literally less then 5 seconds to "rescan MIDI".

it is not like you have to do it 10 times per day. for me is not a problem, but small inconvenience. 

 

i think that setup X1 and Z1 is probably more complete, but it is also more bulky and more expensive. And you can not use it for 3-4 decks :) Traktor equipment is not using midi by default that's why it works different and simpler, but you can not configure it as you want in this mode.

 

i prefer mine Xone K2 that i use with Traktor Audio 2 soundcard when i travel far, when i can i prefer much more Traktor s4 ;)

Share this post


Link to post
Share on other sites

Mønsterhed,

 

i believe that is related to midi protocol and it takes literally less then 5 seconds to "rescan MIDI".

it is not like you have to do it 10 times per day. for me is not a problem, but small inconvenience. 

 

i think that setup X1 and Z1 is probably more complete, but it is also more bulky and more expensive. And you can not use it for 3-4 decks :) Traktor equipment is not using midi by default that's why it works different and simpler, but you can not configure it as you want in this mode.

 

i prefer mine Xone K2 that i use with Traktor Audio 2 soundcard when i travel far, when i can i prefer much more Traktor s4 ;)

I agree with both :)

 

X1&Z1 = simple and easy

but

takes more space, more expensive than one Xone K2 and still just 2 track...

 

personally i use the X1 & Z1 setup at home and i would prefer the Xone for gigs! 

'rescan MIDI' is indeed a 5 sec job and you are set!

 

still looking for a plug & play 4 track solution though :)

S4 is getting old, S5 too expensive and i don't know if it will work as well with 'ggrr' yosemite :)

Share this post


Link to post
Share on other sites

Even though the S4 is getting old it still does the job pretty well. It does everything I'd want a controller to do with regards to 4-deck mixing, but I wouldn't want to drag it around to gigs out of country. Locally, sure, but that's about the extent I'd use it to.

 

I've considered two X1's for 4-deck mixing but would need an audio interface with 8 outs and they don't grow on trees if you don't want it to break the bank.

Share this post


Link to post
Share on other sites

you can find NI Audio 8 , Audio 10 second hand. In France the best site for this is => fr.audiofanzine.com

 

and if you play at the venue that has DJM900 Nexus - you can use it as soundcard, is easy. Just need to install drivers in advance. I used it recently, just one USB cable to connect and you are good to go.

Share this post


Link to post
Share on other sites

you can find NI Audio 8 , Audio 10 second hand. In France the best site for this is => fr.audiofanzine.com

 

and if you play at the venue that has DJM900 Nexus - you can use it as soundcard, is easy. Just need to install drivers in advance. I used it recently, just one USB cable to connect and you are good to go.

 

That's actually pretty neat. I totally forgot they could do that. I'll have to check that out next time I play with one of those :) 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...